SSD no show in system startup???


Hi, Newb here with my first post. I have a 2009 mac pro 2-quad 2.66 8 core nalahem. I put an ssd drive in and installed lion 10.7.3 via the option key and dvd, worked fine. My pro tools version is not compatible with lion and i don't have 700$ lying around, so i decided to wipe the ssd and install leopard. I single partitioned the 90g ssd drive guid partition "mac OS extended (journaled)" and all seems fine in disk utility.

1. The drive won't show up in system startup under preferences?
2. "Option" start won't show SSD drive?
3. "Option" with OSX leopard or lion disk won't show ssd and freezes upon entering dvd as boot option

I think if i can get the ssd to show up in the system startup, the rest should take care of itself?

I partitioned the ssd on the virgin install, then did option start with lion dvd and it showed the ssd and worked perfectly!...did i wipe and reformat incorrectly?

Excuse my ignorance as i know you guys are gurus.
Thanx for any help.
Welcome! :)

I installed an SSD on my MacBook yesterday and it's working OK. I set the format to Journalled HFS+ There were other options for the format but this was the one offered, so I went with it. Is your's formatted this way?

I checked the Option start on mine and it shows the disk as normal. I did have a bit of trouble seating the disc. I suppose that in the MacPro it's a lead with a connector, so bad seating is not likely.

Sorry I can't be more helpful.
Check the partition map type: you'll want to have a partition map of type "GUID" (not MBR or APM).

You can do this by booting from the OS X install CD/DVD, entering Disk Utility, clicking on the SSD device (not the indented partition underneath), and then clicking "Options..." and checking the partition map type.
Here is the display in disk utility, I still haven't figured out how to get it int syterm preferences startup disk?????

Name : Corsair Force 3 SSD Media
Type : Disk

Partition Map Scheme : GUID Partition Table
Disk Identifier : disk1
Media Name : Corsair Force 3 SSD Media
Media Type : Generic
Connection Bus : SATA
Connection ID : "Bay 1"
Device Tree : IODeviceTree:/PCI0@0/SATA@1F,2/PRT2@2/PMP@0
Bay : "Bay 1"
Writable : Yes
Ejectable : No
Location : Internal
Solid State Disk : Yes
Total Capacity : 90.03 GB (90,028,302,336 Bytes)
Disk Number : 1
Partition Number : 0
S.M.A.R.T. Status : Verified

Any help is appreciated, thnx
You said that you erased the SSD
The SSD will not show as a startup disk, unless you have a boot system installed on the SSD.
If there is nothing installed on the SSD partition, then try booting to your original restore DVD (the 10.5.6 one, I think), run Disk Utility from the Utilities menu. Click on the SSD model number line, and click the partition tab. Click the drop down for Partition Scheme, and choose 1 partition, and click the Apply button. That should then allow your SSD to be used to install 10.5 again.