Western digital hard drive


i could drag things to my HD before but now nothing does-- permissions are "read only" so how do i change it so i can put more things on my HD?

so annoying, hoping you can help
If that is what the problem is; highlight the WD and 'get info' on it. Toward the bottom, give yourself read/write permission.
Assuming this is an external HD, select the drive then command I or get info. At the very bottom there is a padlock icon, click it and a box will appear wanting and administrator password. Enter password then look for a checkbox that says "ignore permissions on selected volume" and check it.
thats weird cos usually there would be something like a padlock. but no, still nothing like that .. :( wonder why its doing this.. the hard drive works in my windows netbook, i tested it.. its worked in my laptop before.. the format is NTFS..that ok? i formatted it so it can work on my windows and mac
So, did it change to read-only on your Mac AFTER you formatted it NTFS? (that would be correct!)
OS X is read-only for NTFS, so you can't natively copy files to that drive, or modify files that already are on the drive.
hmm.. i could have sworn ive used it after that but not sure.. ive not used it on my mac since i converted to lion either.. so is there any way i can make it to work on my mac and windows?
There's two methods.
Install NTFS driver software on your Mac, such as NTFS-3G (free), or Tuxera NTFS for Mac (commercial, maybe about $30).
Or, erase your external, and reformat as a Mac drive.
You'll need to install something like "MacDrive" on your Windows system to use the Mac-formatted volume.
The NTFS-3G (Tuxera is the name of the software that is the commercial version of NTFS-3G, with higher performance) does not affect your external hard drive in any way. It simply provides your OS X system with the capability - drivers - to read/write to that NTFS-formatted drive.
I PRESSED ENABLE IN SYSTEM PREFERENCES FOR NTFS 3G- PLUGGED HD IN AND GOT THIS ERROR MESSAGE: it couldnt mount the HD, so how do i get it to work with this new program?
What was the error message?

Maybe you need to uninstall the older Tuxera software, then try the NTFS-3G.
There's uninstall instructions in the Tuxera manual, but you can start with the Uninstall button in the Tuxera Pref pane in your System Preferences.
The Tuxera blog page does say the the NTFS-3G is not usable on a 64-bit system, and (I think) the Tuxera software has 64-bit support. I don't know if that means you can't use NTFS-3G with a Lion system (or if it works at all with Lion)
Why not just purchase the paid software (which is much faster than the free version - supposedly to make the purchase choice easier?)
no i dont wanna pay for software.. ah i see, so i need a free one that works with lion, annoying tuxera did.. i got this error message: NTFS-3G could not mount /dev/disk1s2 at /volumes/hard drive because the following problem occured : dyld: library not loaded: /usr/local/bin/ntfs-3g reason: image not found

annoying it worked before i had lion
ah i saw it, so do you want me to uninstall the software then plug HD in and see if it works or to unistall the software and download it again? i need a free one that will work
Uninstall the NTFS software, then reinstall it.
From what I read, you may be SOL with the free version on Lion, perhaps because of no 64-bit support. You went past that when you upgraded to Lion, which defaults to 64-bit.
If it does work, and you want 'free', then you may have to put up with some instability, and certainly slow performance.
If you want that NTFS drive to work "OK", then you need to get the commercial version.

My feeling is that you want to ask yourself if you really need to share your drive with a Windows PC.
is the commercial version the tuxera one? i dont mind if its slow as long as i can transfer my files across.. if i got the tuxera then surely it would expire again and then id just have to unistall and install? i need a free version of that if there is any
I already did go into detail about which is paid, and which is free.
re-read post #12, and check the link there for some more info at the Tuxera blog.
And, just to remind you - I'm not convinced that the free version will work in Lion, you'll just need to try it. That's also why I recommend uninstalling, then reinstalling (regardless of the version that you have already used.) That can make sure that whatever you have has the best chance to work. And, an expired version needs to be removed, in any case. There's an uninstall button in the Tuxera app.