Lion -- cannot move desktop icons


U.S.D.A. Prime
Strange problem.

2009 Mac mini 2.0GHz, Mac OS X 10.7.3 (fully up-to-date).

I cannot rearrange my desktop icons. When I try and drag them, there is a white "not allowed" ("no smoking"-style) symbol beside the cursor while dragging.

I just noticed now that screenshots no longer work via the keyboard shortcuts, either -- the snapshot sound occurs, and no file appears on the Desktop.

Permissions, repaired. Disk, checked and validated. Computer, rebooted. User account, logged in and out.

This problem has existed since 10.7.2. I never realized how little I rearrange icons on my desktop until I no longer could.



I guess there's some standard questions, eh?

Snapshot doesn't add a file to your desktop - so, can you move ANY file (or add one) to your desktop? A good choice might be to try to add a new folder?
Check in Get Info for your Desktop folder. Is your desktop folder locked? I just tried that, and moving an icon shows the 'not allowed' symbol, and I can't move any icons. That's likely it, eh?

If that doesn't help you -
Is your desktop still locked when you log out, then log back in to another account?


U.S.D.A. Prime
Taking a screenshot with command-shift-3 does, in fact, add the resulting .png file to the Desktop -- but those resulting file icons are not movable. I can delete them, though (either by dragging to the trash in the Dock, or pressing the "Move to trash" hotkey [command-delete]).

I cannot create a new folder on the Desktop. The hotkey (command-shift-n) doesn't work (it does specifically nothing) and the "File" menu item is grayed out (see attachment).

Desktop folder is not locked. Locking it and unlocking it has no effect on the problem.

Creating a new user results in a user account that works correctly. I am nostalgic and would prefer not migrating to a new user account, since this one's been around forever.

Permissions seem correct (other attachment).




iMovie Professional
If creating a new account works, I wonder if deleting the Desktop folder would cause OS X to create a new, working folder on your current account after a reboot. You would need to delete the folder from another account or force it in terminal as OS X will not want to cooperate. You should probably also have a backup.
Odd problem though.


In Geostationary Orbit
Also maybe deleting the finder Preferences file (you'll have to reset your Finder Preferences after). Find the Preferences in ~/Library/Preferences/ and other Finder files. See if that helps.

Plus let us know if a new test account has the same problem.


U.S.D.A. Prime
All new user accounts work correctly, as they should. Just mine doesn't.

By deleting the .DS_Store file, I was able to get my Desktop to remove the prohibited ("no smoking") symbol, but the actual results are the same -- icons simply snap back into their original place when dragged.

I've also checked the Finder and View preferences to ensure nothing like "Auto-arrange by name/kind/date" were enabled.


U.S.D.A. Prime
Deleting the Finder preferences didn't help.

Took the step of removing the Desktop folder from my account from another admin account, logged back in, and everything works great now.

Strange problem, since I'll probably never be able to track down the exact cause. Thanks to all.


I believe I have the same problem. Any ideas on how to fix it free and easy?

Thank you!


Chmod 760
Staff member
Have you by any chance used anything like OnyX or other utility tools?
Some of them, or at least one of them (that I don't remember the name of) had that in some option. I had the same problem a long time ago in my 10.3 machine - I had run one of these utilities, and didn't notice or remember that I had changed that option. Nothing worked (except of course on new accounts) until I run that program again.
In my case I think it wasn't OnyX but something like it. Some multi-tool utility/management app.