Mac OS X 10.4.11 only working in Safe Mode

ragnarok0273

Registered
I have an iMac G5 A1058. ALS, 2 GHz.
It only works properly in Safe Mode.
I've tried reinstalling multiple times with an OS X 10.4.6 disc and an OS X 10.4.11 disc. I looked in Verbose Mode and it showed this:
IOHW Monitor - no Params Version !!
Does anyone know what this error means?
Thank you!
 

DeltaMac

Tech
What is the problem that you see when you let the system boot normally?

What hardware do you use with your iMac G5 (external drives, audio interface, external display, etc.)

Do you need to stay with 10.4 Tiger?
 

ragnarok0273

Registered
1. When I boot it normally? It just ends up on a blank light blue screen. The mouse cursor pops up after a minute or so, but nothing else happens.
2. Everything is default except the background and the storage drive. The HDD died (booted it up and I heard "vrrrrRRRr-SCREEEEEECH" so I swapped it with a Samsung 850 EVO 250GB SATA III 2.5" SSD that I had laying around. Formatted it to Apple Partition Table with Mac OS X Extended (Journaled) with my Mac Mini 2011, stuck it in (used an adapter to make it fit, but no passthrough), and installed OS X to it.
3. No, but I don't have a way to install 10.5 on it. I've tried an original 10.5.6 DVD and the Open Firmware USB trick, but it won't work (shows the prohibited sign) and that's all I can find.
I've tried resetting the PRAM, resetting Open Firmware, replacing the battery, and (I think) resetting the SMC. If I didn't do it right (unplugging it and leaving it overnight) please correct me :)
 

SGilbert

Registered
"....and (I think) resetting the SMC. If I didn't do it right (unplugging it and leaving it overnight) please correct me :)"

If I remember correctly, there is a small black 'button' near the power supply. DeltaMac will correct me if I'm mistaken.
 

DeltaMac

Tech
SMC reset on your iMac ALC G5 is just unplugging everything from the back, wait 10 seconds, then plug in the power cord while simultaneously pressing and holding the power button on the back of the computer.
Release the power button, then press the power button again to start up your iMac.
( @SGilbert -- no, there's an internal power button near the upper fan, but no reset button on this model :) )

But, your iMac seems to function, with a working display, and you get to the desktop in Safe Boot mode?

Apple's Service Diagnostic (ASD version 2.5.8, IIRC.) has an "OSX boot" which tests how the hardware reacts to an operating system. I would run that on your iMac, if you can find the download for that ASD disk. The CDs don't exist for sale sanywhere, as far as I know. You have to find the download (disk image) that makes the CD, and I'm not sure where you could go to find that.
Here's a page with potential downloads. Scroll about 3/4 down the page for ASD-2.5.8.zip
That's the version you want for your G5 iMac. I didn't try the download to see if it actually links to something (Apple official downloads tend to get removed without warning) This link appears to download a large number of files, so you want to view the results, looking for Apple's file number, which is 693-5964-A. You might also see it listed as Apple Service Diagnostic (ASD) v.2.5.8 -- or something similar. It will explain in the file how to make the CD from the file. (Good luck on that if you want to try)

So, you see --- I suspect that you have a problem on the logic board, or could even be a failing (weak) power supply.
 

ragnarok0273

Registered
Booted it up and it said:

Error 1 loading Geneva10
Error 1 loading Courier10
Error 1 loading Charcoal12
Error 1 loading gFontArialBlack24

+--------------------------------------------+
| |
| Standalone Diagnostics v21.0.2 |
| |
+--------------------------------------------+
Enter Script Name or Command (main.sc):
 

DeltaMac

Tech
What is the "it" that you booted?
The Apple Service Diagnostics?
Which boot choice did you make? (There's two. Did you try both, and only the one failed?)
Did you burn that to a CD? Looks like it is missing the fonts to show the GUI for the diagnostics, which would certainly make it fail to set up the test.
I "restored" the disk image to a small partition on a hard drive. Works better than that CD, particularly if you have an original optical drive, which could simply have intermittent problems reading disks - due to age.

Or, if you made the bootable diagnostic disk correctly, you may have a problem with your Mac's memory, and it's not loading the diagnostic into RAM correctly (which could also be the cause for not booting to the normal system boot.)
The hardware test CD for that IMac might work better for you, and should help you decide if your memory is OK.
This link should work for that, if you don't have the version 2.5.3 hardware test for your old iMac.
iMac v2.5.3GMc1
If you can boot to that hardware test, run both the normal, and extended tests. You want a "pass" on both tests.
 

DeltaMac

Tech
I would also probably replace the PRAM battery. It's likely the original piece, and although not really related, an under-voltage (or dead) battery might contribute to an odd issue or two.
 

ragnarok0273

Registered
I have done so - and it turns out the 1632 was dead.
It still hasn't changed anything.
Still the same
IOHW Monitor - no Params Version !!
error in Verbose Mode.
 

DeltaMac

Tech
I've searched for that IOHW, and have not found much.
Try an open firmware reset....
Boot holding Option-Command-O and F (that's a letter O, not a number zero.
You will get a text screen, showing a line that displays your firmware version on the iMac.
Type:
reset-nvram
Press enter, you should an OK, then type
set-defaults
Press enter, and you should again get an OK. Finally, type
reset-all
Press enter, your iMac will restart.
When you hear the chime, immediately hold Option-Command-P-R (nvram/PRAM reset)
You should hear the boot chime sound again. Keep holding the same 4 keys until you get two more boot chimes, then release all except Option, so you will get your boot-picker screen. Select your drive, and click the right-facing arrow. When you boot, be sure to select your boot drive in the System Preferences/Startup Disk pane.

If that doesn't help (and you are not back to a normal boot, you should try a 10.4.6 install again.
With the various problems I have had over the years getting installer DVDs that actually will install -- You might get the 10.4.6 installer to work properly from a copy of the DVD.
I keep a few dual layer DVD R just for that purpose. Try burning a copy of your 10.4.6 installer (even if it is an original DVD from Apple.), and try your Tiger install from that copy.

How long since your ALS iMac last worked properly?
 

ragnarok0273

Registered
My 10.4.6 disc is a burned disc that I made.
It's a DVD+R.
I got the iMac from a relative with the exact same problem - except it had 10.5.8 on it. I can't put this on it though, as my 10.5.6 disc results in the same problem and when I try from USB it gives the "prohibited" sign.
The first time I got it, I put 10.4.6 on it with the HDD in there, and it worked fine.
I came back the next day and it gave the blank light blue screen when I booted it up, so I restarted it and then the hard drive gave out.
I then installed 10.4.6 on the SSD and it has been giving this problem ever since.

I will try the Open Firmware thing - all I've done there is the USB boot command.
 
Last edited:

ragnarok0273

Registered
Update:
I tried the Open Firmware thing and a fresh install (complete wipe of the drive), no change.
I also tried restoring a 10.5.4 image (I have one, just no DL DVDs) to a small partition on the drive and it gave the blank light blue screen.
 
Top